Route filtering passive interface OSPF.

images
Cisco News
Route filtering passive interface OSPF.

Recently, OSPF is a hot topic in the IT industry. SPOTO has cast its eye into the technology. What’s more, SPOTO also involves all kinds of certification exam such as CCIE, CCNA, CCNP, CISSP, AWS, Huawei and online training courses and so on. The following is to introduce some examples of OSPF. I hope it’s helpful for you.

Passive interface

Cisco IOS offers various ways to control updates traffic. Passive interface, distribute list, prefix list route maps. In this section, we will introduce a passive interface in RIPv2, EIGRP, and OSPF.

Passive interface command is used in all routing protocol to disable sending updates out from a specific interface. However, the command behavior ranges from one protocol to another.

A passive interface in OSPF

In OSPF passive-interface, work just like it does with EIGRP. OSPF can’t send any hello messages on passive interface its means no neighborship but still advertises about the connected subnet if matched with an OSPF network command.

let us see the configure:

Topology:

Goal:

·configure the topology as per the diagram 

·configure OSPF and advertise the network

·configure interface serial 4/1 passive interface 

R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        10.1.1.1        YES manual up                    up

Serial4/0              1.1.1.1         YES manual up                    up

R2#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial4/0              1.1.1.2         YES manual up                    up

Serial4/1               2.1.1.1         YES manual up                    up

R3#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        30.1.1.1        YES manual up                    up

Serial4/1               2.1.1.2         YES manual up                    up

Loopback0              13.0.0.1        YES manual up                    up

Loopback1              13.0.1.1        YES manual up                    up

Loopback2              13.0.2.1        YES manual up                    up

Loopback3              13.0.3.1        YES manual up                    up

Loopback4              13.0.4.1        YES manual up                    up

R1(config)#router ospf 1

R1(config-router)#network 10.0.0.0 0.255.255.255 area 0

R1(config-router)#network 1.0.0.0 0.255.255.255 area 0

R1(config-router)#exit

*Apr  4 14:25:00.243: %OSPF-5-ADJCHG: Process 1, Nbr 20.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done

R2(config)#router ospf 1

R2(config-router)#network 1.0.0.0 0.255.255.255 area 0

*Apr  4 14:25:00.403: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done

R2(config-router)#network 20.0.0.0 0.255.255.255 area 0

R2(config-router)#network 2.0.0.0 0.255.255.255 area 0

R2(config-router)#exit

*Apr  4 14:27:09.607: %OSPF-5-ADJCHG: Process 1, Nbr 13.0.4.1 on Serial4/1 from LOADING to FULL, Loading Done

R3(config)#router ospf 1

R3(config-router)#network 30.0.0.0 0.255.255.255 area 0

R3(config-router)#network 30.0.0.0 0.255.255.255 area 0

R3(config-router)#network 13.0.0.0 255.0.0.0 area 0

R3(config-router)#network 2.0.0.0 0.255.255.255 area 0

R3(config-router)#exit

*Apr 4 14:27:09.567: %OSPF-5-ADJCHG: Process 1, Nbr 20.1.1.1 on Serial4/1 from LOADING to FULL, Loading Done

router 2 facing router 1 established connection 

router 2 facing router 3 established connection

let's see the routing table

R1#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     2.0.0.0/8 [110/128] via 1.1.1.2, 00:07:57, Serial4/0

      13.0.0.0/32 is subnetted, 5 subnets

O        13.0.0.1 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

O        13.0.1.1 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

O        13.0.2.1 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

O        13.0.3.1 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

O        13.0.4.1 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

O     20.0.0.0/8 [110/65] via 1.1.1.2, 00:07:57, Serial4/0

O     30.0.0.0/8 [110/129] via 1.1.1.2, 00:07:57, Serial4/0

R2#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     10.0.0.0/8 [110/65] via 1.1.1.1, 00:11:44, Serial4/0

      13.0.0.0/32 is subnetted, 5 subnets

O        13.0.0.1 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

O        13.0.1.1 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

O        13.0.2.1 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

O        13.0.3.1 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

O        13.0.4.1 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

O     30.0.0.0/8 [110/65] via 2.1.1.2, 00:19:36, Serial4/1

(configure passive interface serial 4/1 on router 2 facing router 3)

R2(config)#router ospf 1

R2(config-router)#passive-interface serial 4/1

*Apr  4 14:48:54.387: %OSPF-5-ADJCHG: Process 1, Nbr 13.0.4.1 on Serial4/1 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-router)#end

R1#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     2.0.0.0/8 [110/128] via 1.1.1.2, 00:13:49, Serial4/0

O     20.0.0.0/8 [110/65] via 1.1.1.2, 00:13:49, Serial4/0

R2#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     10.0.0.0/8 [110/65] via 1.1.1.1, 00:17:28, Serial4/0

router 3 2.1.1.2 is sending hello messages but router 2 2.1.1.1 is not responding 



Cisco Pass Report View More >

CCIE RS Written
Aug 23, 2019
CCIE RS Written
CCIE SP Lab
Aug 22, 2019
CCIE SP Lab
CCIE RS Lab
Aug 22, 2019
CCIE RS Lab
CCIE Wireless Written
Aug 22, 2019
CCIE Wireless Written
CCIE SP Lab
Aug 22, 2019
CCIE SP Lab
CCIE Data Center Written
Aug 22, 2019
CCIE Data Center Written
CCIE Wireless Written
Aug 21, 2019
CCIE Wireless Written
CCIE Data Center Written
Aug 21, 2019
CCIE Data Center Written
CCIE RS Lab
Aug 21, 2019
CCIE RS Lab
CCIE RS Written
Aug 20, 2019
CCIE RS Written