The Useful Means to Configure OSPF Virtual Links.

images
Cisco News
The Useful Means to Configure OSPF Virtual Links.

In all areas, an Open Shortest Path First (OSPF) autonomous system must be physically connected to the backbone area (Area 0). In some cases, we can use a virtual link to connect to the backbone (Area 0) through a non-backbone area. if this is not possible, We can also use the virtual links to connect two parts of a partitioned backbone (Area 0) through a non-backbone area. The area through which we configure the virtual link, known as a transit area, must have full routing information. Remember the transit area cannot be a stub area.

SPOTO is committed to all kinds of certification exams and provides some free study materials that will be helpful to you. Don’t hesitate to contact us, and you will find some useful information for you.

The virtual link must be configuring both sides with the same area ID and the corresponding virtual link OSPF neighbor router ID. Show IP OSPF neighbors command give you the router ID information.

1.area-id

Is an identifier for the OSPF area assigned to the transit area for the virtual link. OSPF area ID can be from 0 to 4294967295 or an IP address.

2.router-id

The router ID is associated with the virtual link neighbor. Specify as an IP address. The router ID appears in the show IP OSPF neighbors command.

In short: virtual link is used to connect a discontiguous area to area 0, a virtual link is a logical connection built between routers, virtual links are recommended for backup or temporary connections.

configuration virtual link:

Topology:

GOAL:

·Configure interfaces and assigned IP addresses as per the Topology

·advertise the interfaces using multiple areas defined as per the Topology

·configure the manual router id (RID) R1-11.1.1.1, R2-22.1.1.1, and R3-33.1.1.1

·make sure that the loop-back of R1- 11.0.0.0 routes should be seen on all the other routers

R1#show ip interface brief

Interface              IP-Address      OK? Method Status           Protocol

FastEthernet 0/0    10.1.1.1       YES manual up                  up

Serial3/0               1.1.1.1           YES manual up                    up

Loopback0             11.0.0.1        YES manual up                    up

Loopback1             11.0.1.1        YES manual up                    up

Loopback2             11.0.2.1        YES manual up                    up

Loopback3             11.0.3.1        YES manual up                    up

R2#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial3/0                     1.1.1.2         YES manual up                    up

Serial3/1                     2.2.2.1         YES manual up                    up

R3#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        30.1.1.1        YES manual up                    up

Serial3/1                    2.2.2.2         YES manual up                    up

Serial3/2                    3.3.3.1         YES manual up                    up 

R4#show ip interface brief

Interface              IP-Address      OK? Method Status        Protocol

FastEthernet0/0   40.1.1.1        YES manual up                    up

Serial3/2              3.3.3.2         YES manual up                     up

Loopback0           14.0.0.1        YES manual up                    up

Loopback1           14.0.1.1        YES manual up                    up

Loopback2           14.0.2.1        YES manual up                    up

Loopback3           14.0.3.1        YES manual up                    up

R1(config)#router ospf 1

R1(config-router)#router-id 11.1.1.1

R1(config-router)#NETwork 1.0.0.0 0.255.255.255 Area 20

R1(config-router)#NETwork 10.0.0.0 0.255.255.255 Area 20

R1(config-router)#NETwork 11.0.0.0 0.0.0.255 area 10

R2(config)#router ospf 1

R2(config-router)#router-id 22.1.1.1

R2(config-router)#network 1.0.0.0 0.255.255.255 area 20

R2(config-router)#network 2.0.0.0 0.255.255.255 area 20

R2(config-router)#network 20.0.0.0 0.255.255.255 area 20

R3(config)#router ospf 1

R3(config-router)#router-id 33.1.1.1

R3(config-router)#network 2.0.0.0 0.255.255.255 a 20

R3(config-router)#network 3.0.0.0 0.255.255.255 area 0

R3(config-router)#network 30.0.0.0 0.255.255.255 area 20

R4(config)#router ospf 1

R4(config-router)#network 3.0.0.0 0.255.255.255 area 0

R4(config-router)#network 40.0.0.0 0.255.255.255 area 0

R4(config-router)#network 14.0.0.0 0.0.0.255 area  0

R2#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  3.0.0.0/8 [110/128] via 2.2.2.2, 00:28:48, Serial3/1

O     10.0.0.0/8 [110/65] via 1.1.1.1, 00:31:39, Serial3/0

      14.0.0.0/32 is subnetted, 1 subnets

O IA     14.0.0.1 [110/129] via 2.2.2.2, 00:26:24, Serial3/1

O     30.0.0.0/8 [110/65] via 2.2.2.2, 00:29:55, Serial3/1

O IA  40.0.0.0/8 [110/129] via 2.2.2.2, 00:26:39, Serial3/1

R3#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 2.2.2.1, 00:29:41, Serial3/1

O     10.0.0.0/8 [110/129] via 2.2.2.1, 00:29:41, Serial3/1

      14.0.0.0/32 is subnetted, 1 subnets

O        14.0.0.1 [110/65] via 3.3.3.2, 00:27:06, Serial3/2

O     20.0.0.0/8 [110/65] via 2.2.2.1, 00:29:41, Serial3/1

O     40.0.0.0/8 [110/65] via 3.3.3.2, 00:27:21, Serial3/2

R4#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  1.0.0.0/8 [110/192] via 3.3.3.1, 00:28:06, Serial3/2

O IA  2.0.0.0/8 [110/128] via 3.3.3.1, 00:28:06, Serial3/2

O IA  10.0.0.0/8 [110/193] via 3.3.3.1, 00:28:06, Serial3/2

O IA  20.0.0.0/8 [110/129] via 3.3.3.1, 00:28:06, Serial3/2

O IA  30.0.0.0/8 [110/65] via 3.3.3.1, 00:28:06, Serial3/2

No routes from 11.0.0.0 coming in to routing table  of R2, R3, R3, and R4 as it belong to area 10 which in not directly connected to area 0

in order to make sure that the loopback of R1 (11.0.0.0) routes should be seen on all the other routes we need to configure Virtual-link which allows area 10 to area 0 virtually over area 20 virtual area.

R1#show ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "ospf 1"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Router ID 11.1.1.1

  Number of areas in this router is 2. 2 normal 0 stub 0 nssa

  Maximum path: 4

  Routing for Networks:

    1.0.0.0 0.255.255.255 area 20

    10.0.0.0 0.255.255.255 area 20

    11.0.0.0 0.0.0.255 area 10

  Routing Information Sources:

    Gateway         Distance      Last Update

    22.1.1.1             110      00:37:30

    33.1.1.1             110      00:32:35

  Distance: (default is 110)

R3#show ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "ospf 1"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Router ID 33.1.1.1

  It is an area border router

  Number of areas in this router is 2. 2 normal 0 stub 0 nssa

  Maximum path: 4

  Routing for Networks:

    2.0.0.0 0.255.255.255 area 20

    3.0.0.0 0.255.255.255 area 0

    30.0.0.0 0.255.255.255 area 20

  Routing Information Sources:

    Gateway         Distance      Last Update

    11.1.1.1             110      00:35:57

    14.0.3.1             110      00:33:22

    22.1.1.1             110      00:35:57

  Distance: (default is 110)

R1(config)#router ospf 1

R1(config-router)#area 20 virtual-link 33.1.1.1

R3(config)#router ospf 1

R3(config-router)#area 20 virtual-link 11.1.1.1

R2#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  3.0.0.0/8 [110/128] via 2.2.2.2, 00:40:25, Serial3/1

O     10.0.0.0/8 [110/65] via 1.1.1.1, 00:43:16, Serial3/0

      11.0.0.0/32 is subnetted, 1 subnets

O IA     11.0.0.1 [110/65] via 1.1.1.1, 00:02:47, Serial3/0

      14.0.0.0/32 is subnetted, 1 subnets

O IA     14.0.0.1 [110/129] via 2.2.2.2, 00:38:01, Serial3/1

O     30.0.0.0/8 [110/65] via 2.2.2.2, 00:41:32, Serial3/1

O IA  40.0.0.0/8 [110/129] via 2.2.2.2, 00:38:16, Serial3/1

R3#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 2.2.2.1, 00:41:43, Serial3/1

O     10.0.0.0/8 [110/129] via 2.2.2.1, 00:41:43, Serial3/1

      11.0.0.0/32 is subnetted, 1 subnets

O IA     11.0.0.1 [110/129] via 2.2.2.1, 00:03:18, Serial3/1

      14.0.0.0/32 is subnetted, 1 subnets

O        14.0.0.1 [110/65] via 3.3.3.2, 00:39:08, Serial3/2

O     20.0.0.0/8 [110/65] via 2.2.2.1, 00:41:43, Serial3/1

O     40.0.0.0/8 [110/65] via 3.3.3.2, 00:39:23, Serial3/2

R4#show ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  1.0.0.0/8 [110/192] via 3.3.3.1, 00:40:10, Serial3/2

O IA  2.0.0.0/8 [110/128] via 3.3.3.1, 00:40:10, Serial3/2

O IA  10.0.0.0/8 [110/193] via 3.3.3.1, 00:40:10, Serial3/2

      11.0.0.0/32 is subnetted, 1 subnets

O IA     11.0.0.1 [110/193] via 3.3.3.1, 00:03:35, Serial3/2

O IA  20.0.0.0/8 [110/129] via 3.3.3.1, 00:40:10, Serial3/2

O IA  30.0.0.0/8 [110/65] via 3.3.3.1, 00:40:10, Serial3/2

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

33.1.1.1          0   FULL/  -           -        2.2.2.2         OSPF_VL0

22.1.1.1          0   FULL/  -        00:00:32    1.1.1.2         Serial3/0

R1#show ip ospf virtual-links

Virtual Link OSPF_VL0 to router 33.1.1.1 is up

  Run as a demand circuit

  DoNotAge LSA allowed.

  Transit area 20, via interface Serial3/0

 Topology-MTID    Cost    Disabled     Shutdown      Topology Name

        0           128       no          no            Base

  Transmit Delay is 1 sec, State POINT_TO_POINT,

  Timer intervals configured, Hello 10, Dead 40, Wait for 40, Retransmit 5

    Hello due in 00:00:04

    Adjacency State FULL (Hello suppressed)

    Index 1/2, retransmission queue length 0, number of retransmission 0

    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

    Last retransmission scan length is 0, maximum is 0

    Last retransmission scan time is 0 msec, maximum is 0 msec

R4#ping 11.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 80/131/172 ms



Cisco Pass Report View More >

CCIE Data Center Lab
Sep 22, 2019
CCIE Data Center Lab
CCIE RS Written
Sep 21, 2019
CCIE RS Written
CCIE RS Written
Sep 21, 2019
CCIE RS Written
CCIE RS Written
Sep 21, 2019
CCIE RS Written
CCIE RS Written
Sep 20, 2019
CCIE RS Written
CCIE RS Written
Sep 20, 2019
CCIE RS Written
CCIE SP Written
Sep 20, 2019
CCIE SP Written
CCIE RS Lab
Sep 20, 2019
CCIE RS Lab
CCIE RS Lab
Sep 20, 2019
CCIE RS Lab
CCIE RS Lab
Sep 20, 2019
CCIE RS Lab